这是一个笔记博客

分类标签

当前:首页 > 在使用rvm和bundle的时候,支持泛版本的ruby

在使用rvm和bundle的时候,支持泛版本的ruby

2018-04-29 14:29    浏览量:0    作者

Gemfile 中可以配置ruby的版本

可以使用  ruby '~> 2.4.0' 这种泛版本定义

 

但是呢,在使用rvm时,进入rails项目后,会读取Gemfile中的ruby版本

这个功能也挺好的,帮助你自动切换rvm中的ruby版本,但是呢rvm不支持这个 '~> 2.4.0' 泛版本语法

 

然后这个就有点尴尬了。。。幸亏查到这个资料:

https://rvm.io/workflow/projects

里面说,rvm为了兼容旧版本bundle,他会读取Gemfile中的注释内容(#ruby=2.4)

 

于是乎,我们的终极解决方案是在Gemfile中写两句:

ruby '~> 2.4.1'

#ruby=2.4

 

第一句给bundle来读

第二句给rvm来读

 

完美~

推荐阅读